2020年07月

2020年07月21日

ワイヤレスHDMI

HOLLYLAND MARS最近、PCをTVにつなぐことが良くあります。Web会議の時につなげたりとか。で、HDMIケーブルを多用するわけですが、遠距離で接続する場合には極太のHDMIで取り回しに苦労したり、SDIに変換してみても変換アダプタに電源供給しなくちゃいけなかったりと、どうも今一つなわけです。で、以前には安価な1万円くらいのワイヤレスHDMI等を買ってみたこともあったわけですが、飛距離も安定しないし実用にならず。で、今回業務用のちゃんとしたやつを買ってみました。HOLLYLAND MARS 400Sというやつです。SDI入力も可能です。

で、これが届いて驚いたのは本体は送信機と受信機で2台あるのに、ACアダプタが1つしか同梱されていません。欠品なのか最初から1つなのかわかりませんが、どちらにせよ2台動かさなくちゃいけないので使えない。この製品はSONY規格のバッテリーでも稼働するので、結局あとからバッテリーと充電器を購入しました。で、早速使っていますがさすがに安定して動いてくれています。ただ、結局この送信機とはHDMIで接続しなくちゃいけないので、ちょっと本体がうっとおしい。しかも小さなトランシーバーみたいな筐体にファンが内蔵されていて、音がします。とことん業務用ですね。しばらくこれを使ってみようと思っています。

kenjiz at 23:18|PermalinkComments(0) IT 

2020年07月15日

AD connectでのメールアドレス同期

うちの会社もいよいよ本格的にOffice365を活用しようと今更ながら動いているわけですが、ローカルのActive DriectoryドメインコントローラーからAzureADにオブジェクト同期をかけています。AD connectを使っています。ですが、なぜか一部のユーザーにメールアドレスが正しく反映されないという症状が発生。メールアドレスとして、ADのユーザーオブジェクトに設定されているアドレスではなく、「〜@〜.onmicrosoft.com」というメールアドレスが勝手に割り当てられたりします。これが全員ではなく一部の人だったので原因が謎でしたが、よくよく調べた結果、ローカルADのユーザーオブジェクトの属性情報次第という事が判明しました。

ADの仕様のようなのですが、メールアドレスを1つだけ持つ場合はmail属性にそのユーザーのメールアドレスを設定するですが、2つ以上のアドレスを持つ場合はproxyAddresses属性に設定することになっているようです。逆に言うとproxyAddresses属性を持っていると、mail属性は無視されるとのこと。どおりでmail属性にいくら値を設定しても無視されるはずです。つまり、mail属性とproxyAddresses属性の両方に値が設定されているとproxyAddresses属性のみがOffice365側に反映されるのが仕様のようなので、私の謎は解決しました。結局LDIFファイルを作ってローカルADのユーザーオブジェクトから不要な情報を一気に削除することにして、AD connectで同期かけると無事に期待通りの設定になりました。proxyAddresses属性には複数のメールアドレスを設定できますが、プライマリSMTPアドレスは大文字SMTPで属性を設定し、セカンダリSMTPアドレスは小文字smtpで設定します。

ちなみにmail属性もproxyAddresses属性も空っぽだと、MS標準の〜.onmicrosoft.comのメールアドレスが自動で割り当てられます。ちなみにこれ、MOERA(Microsoft Online Email Routing Address)というらしいです。自動割り当てのアドレスの場合、アットマークより前の部分は、
1. mailNickname属性
2. proxyAddresses属性のプライマリSMTPアドレスのエイリアス部
3. mail属性のエイリアス部
4. userPrincipalName属性のエイリアス部
という優先順位で設定されるらしく、結局すべてローカルADの属性次第みたいですね。こういう情報ってなかなか出てこないので困ります。メールサーバとしてMS以外の製品を使っていると、ADユーザーオブジェクトのメールアドレス欄はメモ代わりくらいにしか使っていないのですが、やはりMS帝国に囲まれて生活しようとすると、ちゃんとMSの仕様通りに使わないというけないという事です。まぁ無事に動いてくれて何よりでした。

kenjiz at 23:55|PermalinkComments(0) IT 

2020年07月09日

ハイブリッド車の補機バッテリー

補機バッテリー先日、クラウンの2年目点検があったわけですが唯一指摘されたのはバッテリーの電圧低下。12.27Vで、要充電とのことです。電圧だけ見ると6割程度しか充電されていない計算でしょうか。昔乗っていたV8クラウンマジェスタで頻繁にバッテリーが上がっていたのを思い出します。トルクがありすぎて街中だとエンジン回転をほとんど上げずに走り回れるため、毎回バッテリーが上がって車に乗るたびに充電し、あれ?この車電気自動車だっけ?と自問を繰り返していました。でもハイブリッド車は駆動用バッテリーからDC/DCコンバータを経由して補機バッテリーに常に充電されるはず。つまりエンジンが回っていてもいなくても充電されるはずなのに、なんで充電不足?と思うわけです。

というわけで、だいぶ話は飛ぶのですがOBDII端子から情報を取ろうという事で、昔でいうところのレーダー探知機を買って取り付けてみました。法を犯すようなことはしませんので探知機でなくても良いのですが、まぁコンパクトなサブディスプレイに電圧とかいろいろ表示できたら面白いかな、と思ったわけです。で、セルスターのお手ごろな価格のモデルで、なおかつ最近始まったという噂のレーザー計測に対応したモデルを買ってみました。ホームページで先頭に表示されていたという理由で選んだAR-36LCです。OBDII端子につなげるケーブルも一緒に購入。取り付けは非常に簡単で、両面テープは付属のものではなく3Mのコマンドタブを使用し、配線は適当に押し込んでおけば簡単に設置完了。で、起動させて気づいたのですが、マニュアルに載っている項目がすべて情報取れるわけではないんですね。目当ての補機バッテリー電圧が取れたのでまぁ良いのですが、駆動用バッテリーの充電率とか項目はあるのに表示されず。たぶん新モデルで情報の取り方が変わったのについてこれていないだけのような気もしますが、もうちょっと真面目に対応してもらいたいところです。

で、本題の補機バッテリー電圧ですが、走っていると12.4Vあたりと14.1Vあたりを定期的に行ったり来たりしている感じです。14Vというのは駆動用バッテリーからのDC/DCコンバータから供給されている電圧でしょうから走行中はまぁ14Vで良いのですが、不思議なのは結構な割合で12V台になるんですね。補機バッテリー自体の電圧です。これはおそらくDC/DCコンバータがお休みしているという事だと思いますが、つまりこの状態だといくら走っても補機バッテリーには充電されないことになります。もちろん満充電ならそれでもかまいませんが、12V台の前半で充電止めちゃうのはちょっと早くない?と思うわけです。このあたりは次回、ディーラーに聞いてみたいと思います。



kenjiz at 23:24|PermalinkComments(0)  

2020年07月03日

トヨタのACC制御に物申す

全車速追従アダプティブクルーズコントロール(ACC)がついたクラウンを買ってから2年以上経過しているわけですが、アクセル制御がどうも不満です。自分だったらもっと賢いアルゴリズム作れるぞ、と思えるくらいのレベル。ちょうど「スマートマシンはこうして思考する」という本を読んでいたら自動運転車のところにPID制御の話が出てきていて、そう、問題はこれだと思ったわけです。


実例でいうと、例1:前の信号が赤になってアクセルを離して減速始めるとします。前の車はへたっぴなのでぎりぎりまでブレーキ踏まず、信号手前になって強めにブレーキかけ始めます。そこで、ACCをONにして自動できれいに減速→停止させようとするわけですが、ONにした瞬間に自車よりも前車の方がスピードが速いと、ACCはアクセル踏みこむんです。確かに車速だけ見れば前車の方が速いかもしれない。でも、速度を微分して加速度を見れば前車はブレーキ強めに踏んで減速しているわけです。あと1秒今の加速度が続けば速度は逆転し、自分が減速しなくちゃいけなくなる。なのにここでアクセル踏んじゃうところがどうにもしっくりこない。もしちゃんとPID制御が入っていれば微分するので加速度を見るはずなのですが、ACCの動きをこれまで2年間観察している限りでは加速度は見ていないように感じられます。例外はITS Connectで前車と連動している場合で、その時はスムーズに追従するのでもしかしたら加速度データをやりとりしているのかな?とも感じますが、通常時はまるでダメです。

例2:交差点停車中から信号が青になり前車が発進したとします。自分もブレーキ離してクリープ現象で車が動き出しますが、ここで加速を任せようとACCをONにすると、なぜかACCはここでブレーキ踏むんですね。前車が加速しているにもかかわらずです。信号青でみんなアクセル踏むところでブレーキかけるのは追突されそうでかなり怖い。なので信号青直後にACCは使っちゃいけません。そしてワンテンポ空いて前車との距離が空くと、ACCは急加速して車間を詰め始めます。この動きもスムーズじゃない。これは停車中からACCがONの時も同じです。ボタン操作かアクセル操作で再発進できるのですが、ワンテンポ遅れて急加速、という場面が頻繁に起きます。これも、微分して加速度見なさいよ、という話です。

トヨタであれば優秀なエンジニアいるでしょうし、何でこんなことになってるんですかね?ACC制御は丸ごと外注なのでしょうか?自動運転系は今後必須の技術でしょうし、ちょっとトヨタ大丈夫?と正直思います。頑張ってほしいところです。

kenjiz at 23:53|PermalinkComments(0)  | IT